
Geographic Imager  用户手册



Geographic Imager 5.0 用户手册

版权归© 2015 Avenza 公司所有。 
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可更改且不应视为 Avenza或者相关公司或者子公司的义务。Avenza公司对本教程中可能出现的任何错误、遗漏或者偏差均不承

担责任。  
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1.概述

Geographic Imager 5.0是最新版本的用于 Adobe Photoshop的 Avenza制图插件。 

Geographic Imager跟 Adobe Photoshop集成在一起, 通过在广泛使用的 Adobe Photoshop 环境下对空间影像进行创建、编辑

和管理而彻底改变了传统空间影像的处理方式。Geographic Imager可以使空间影像处理任务在强大的栅格环境下完成，并且

同时利用 Adobe Photoshop数十个强大的工具和操作来对影像进行处理。 

Geographic Imager由 Adobe Photoshop的一系列地理空间工具组成，这些工具会在之前版本的基础上通过添加其它文件格式、

工具和项目的形式继续改进。对于用户来说，Geographic Imager也是 MAPublisher 和 Adobe Illustrator完美的配套软件。  

此教程是假定您对 Adobe Photoshop比较熟悉，至少对 GIS的技术和概念有基本的了解。想了解 Adobe Photoshop特点相关的

更多信息，可以参阅 Adobe Photoshop用户指南。想了解 Geographic Imager 支持的投影方面的更多信息，请参阅Avenza投

影指南－ Projections Guide （该指南在 Help and Tutorial Data 文件夹里)。 

1.1 功能介绍 

以下简要说明了 Geographic Imager 软件的基本功能。 

打开/保存空间影像 

当打开地理影像时，Geographic Imager能自动识别 GIS 栅格格式并且试着查找与之匹配的参考文件。参考信息会显示在

Geographic Imager面板上。当使用 Adobe Photoshop本身的保存命令来保存一个地理影像时，Geographic Imager会自动创

建一个相应的参考文件或者 GeoTIFF头文件信息。Geographic Imager支持所有的 Adobe Photoshop影像导出格式，包括

Adobe Photoshop的原生格式 PSD和 Adobe Acrobat PDF格式。除了 GeoTIFF,大部分的格式都会附带一个外部参考文件（如

world文件）。一些影像格式如果没有安装 Geographic Imager的话，是不能在 Adobe Photoshop里打开的，如 MrSID, 

JPG2000和 DEMs。有一些格式不能存成它原来的格式，而必须存成另一种格式，如 GeoTIFF。想了解更多这方面的内容请参考

打开空间影像。 

投影转换 

Geographic Imager使用了 GeoTransform技术，一种很成熟的影像重投影机制，广泛支持多达几千种大地和地理坐标系统的转

换，能够在 Adobe Photoshop里对影像进行投影转换。另外，Geographic Imager还支持自定义投影。想了解更多这方面的内

容请参阅空间影像投影转换。 

为影像赋参考和进行几何纠正 

Geographic Imager在页面添加了一个世界坐标格网，而 Adobe Photoshop本身有像素格网系统。您在整个 Adobe Photoshop

操作处理过程中都可以创建和保留影像－世界的位置关系，这样当您保存影像的时候就可以完好无损的将正确的地理参考信息

保留下来。具体来讲，Geographic Imager灵活支持大部分影像级的操作，如裁切和重新设置影像大小，并且跟踪影像几何形



状的变化，相应地更新参考信息。Geographic Imager能对不带地理参考的影像添加地理参考，能使用已知控制点通过像素

值、大地坐标或投影坐标对其进行几何纠正。想了解更多这方面的内容请参阅为影像赋参考。 

分幅 

Geographic Imager可以自动将空间影像分割/分幅成多个小影像，同时在每个小影像里保留地理参考信息。对影像分幅的方式

有很多，可以根据需要自行选择。想了解更多这方面的内容请参阅影像分幅。 

镶嵌 

Geographic Imager能自动将多个地理影像合并生成影像镶嵌图，同时在新的大的镶嵌影像里保留地理参考信息。即使用多个

单个的影像文件生成无缝的大影像。想了解更多这方面的内容请参阅影像镶嵌。 

裁切 

根据定义好的裁切范围对地理影像进行裁切。这个工具很实用，可以按您感兴趣的范围来随意裁切影像。想了解更多这方面的

内容请参阅影像裁切。 

高级导入 

使用高级导入工具可以同时导入不同类型的多个文件，还包括很多工具如裁切/重采样、波段管理、DEM 晕渲、镶嵌。 想了解

更多这方面的内容请参阅使用高级导入功能打开影像。 

DEM 方案（DEM schema） 

DEM schema为连续的地形表面提供了一种很有效的信息存储方法。DEM数据需要进行着色处理，这样才能进行可视化显示。根

据 DEM数据类型以及想要的外观效果，您需要对着色方案类型进行自定义或者自动选择着色方案。另外，DEM schema还支持高

程显示以及多个相同着色方案的 DEM影像的镶嵌。想了解更多这方面的内容请参阅打开 DEM schema。 

地形晕渲（Terrain Shader） 

Terrain Shader工具能在 Adobe Photoshop里将晕渲效果和颜色地图动态地应用到数字地形模型上。您可以轻松导入一个 DEM

数据并且根据高程情况快速地着色和赋上阴影效果，并且通过应用特定的光源位置和亮度来达到理想的阴影效果。可以创建自

定义颜色地图或者将 Adobe Photoshop 已有的渐变效果导入用作颜色地图。想了解更多这方面的内容请参阅地形晕渲 DEM 

schma。 

波段管理 

Geographic Imager的 Channel Management 可以将多波段影像的波段进行控制管理，将其任意合并生成假彩色影像或真彩色等。

想了解更多这方面的内容请参阅波段管理。 

自动的工具 

所有的 Geographic Imager命令都完全跟脚本和操作相兼容。 

您可以轻松地创建自定义脚本和操作来实现任务的批处理作业。Geographic Imager JavaScript功能完全可以配置综合参数。

想了解更多这方面的内容请参阅 Geographic Imager自动化批处理。 



 

 

 

导出多种地理空间格式 

Geographic Imager能够导出 Adobe Photoshop所有支持的影像文件格式。当把一个带地理参考的影像存成一个不带地理参考

的格式时(如 JPEG),Geographic Imager会创建一个外部参考文件(例如 World文件)。 

Geographic Imager也可以导出带有内部地理参考信息的文件格式，如：GeoTIFF, BigTIFF, DEM TIFF, Geospatial PDF, 

ERDAS IMAGINE Raster, ECW, MrSID, 和 NITF。想了解更多关于支持的空间影像格式请参照导出空间影像。 

导出 PDF Maps 

使用 Export to PDF Maps来生成地图包并且直接将其上传到 PDF Maps商店（它是安装在 iOS，Android和 Windows Phone上

的 PDF Maps应用程序上的一个地图商店）。它是从电脑到移动设备获取地图最快的方式。想了解更多这方面的内容请参阅导

出 PDF Maps。 

  



 

 

 

2.影像导入教程 

2.1 影像导入和投影转换 

影像导入 

打开一景空间影像跟在 Adobe Photoshop里打开任意其它影像的方式一样。 

1.确保您正确安装了 Geographic Imager。 

2.在 Adobe Photoshop里，点击选择 File > Open。导航找到\Tutorial Data\Americas 文件夹并且同时打开 Americas_1.tif 

和 Americas_4.tif。 

 

确保 Americas_4.tif文件处于激活状态并且打开 Geographic Imager面板。如果没有看到该面板，点击选择 Window > 

Extensions > Geographic Imager。 



 

 

 

 

Americas_4.tif没有地理空间参考信息。但是，您可以为其指定参考信息和一个坐标系统。 

一个参考文件包含描述影像位置、影像大小、像素大小和影像旋转角度的坐标信息。它并不包含实际的影像数据。接下来，您

要给 Americas_4 文档指定一个参考文件。 

3.在 Americas_4.tif 文件为当前激活状态的情况下，在 Geographic Imager面板里点击 Reference file后面的 Specify。 

4.选择 Americas_4_reference.tfw 并点击 Open。 

 



 

 

 

该参考文件 Americas_4_reference.tfw (World参考文件)就在 Geographic Imager面板里列出来了。在 General和 Corners 选

项卡里，也显示了一些空间参考信息，包括影像范围、像素大小和左上角&右下角坐标。 

 

下一步是给这景影像指定一个坐标系统。 

5.保持这些影像为打开状态，下面的教程会用到。 

指定一个坐标系统 

一些参考文件是没有存储坐标系统信息的。例如，前面用到的 tfw world 文件就没有包含任何坐标系统。为了继续做练习，您

需要指定一个源坐标系统。 

当前的 Americas_4.tif currently是没有指定坐标系统的。您要按以下步骤来为其指定跟 Americas_1.tif 一样的坐标系统。 

1.在 Americas_4.tif文件处于激活状态的情况下，点击 Geographic Imager面板里的 Coordinate System选项卡下面的 

Specify 链接。 

 

您可以任选以下两种方法中的一种来给这个文档指定一个坐标系统：从坐标系统库里面选择一种坐标系统或者直接选择已打开

的影像文件的坐标系统。首先，从坐标系统数据库里选择： 

2.在 Specify Coordinate System 对话框里，点击[No Coordinate System Specified] 链接。 



 

 

 

3.在 Select Coordinate System 对话框里，展开 Coordinate Systems > Geodetic > World 目录，在坐标系统列表里选择 WGS 

84 并且点击 OK。 

 

4.在 Specify Coordinate System 对话框里点击 OK。  

 

或者，您可以使用 Same as 选项，因为 Americas_1.tif也是 WGS 84坐标系统。 

 

这样，就给 Americas_4.tif 指定了 WGS 84 坐标系统。该坐标系统的信息也同时在 Geographic Imager面板上更新显示出来

了。 



 

 

 

 

5. 保持这些影像为打开状态，下面的教程会用到。 

坐标系统转换 

坐标系统转换是将一个带有地理参考的原始影像转换到带有另一个不同的坐标系统下。在这个练习里，该影像将从 WGS 84 坐

标系统转换到 British National Grid坐标系统 

1在 Americas_4.tif仍然处于激活状态的情况下，在 Geographic Imager上点击 Transform 按扭。 

 

2.在 Transform对话框，点击 WGS 84 链接来选择一个不同的目标坐标系统。  

这跟指定一个源坐标系统是不一样的。目标坐标系统是影像转换之后的坐标系统。 

3.展开 Coordinate Systems > Projected > North America > United States 目录，在坐标系统列表里选择 United States: 

Lambert Conformal Conic, meter，点击 OK。  



 

 

 

 

这样就设置了用于投影转换的目标坐标系统。此时，在转换处理的过程中 Geographic Imager会自动选择一个合适的基准偏移

量。如果此基准需要修改，点击 Specify 按扭，打开 Specify Datum Shift对话框并且选择需要的基准。想了解更多关于基准

偏移的说明请参阅 Geographic Imager用户指南。 

 

注意，像素大小是 7077.28950515米。该像素大小可以按用户指定的值进行修改。这样在本

质上来说就改变了影像的大小，因为每个像素代表了一个制图单元。在这里，我们将像元大小保

留为默认大小。 

4.点击 Transform 按扭。  



 

 

 

 

这样，影像就被转换到了 Lambert Conformal Conic 投影坐标系统。 

5.点击 Americas_1.tif 文件将其设置成激活状态，点击 Geographic Imager 面板上的 Transform按扭。  

面板上显示的是 WGS84坐标系统。您也可以将其转换到 Lambert Conformal Conic投影坐标系统下。 

6.点击 Same As复选框并且从下拉列表里选择 Americas_4.tif (United States:Lambert Conformal Conic, meter) 。 

7.在提示对话框里点击 Update pixel dimensions to match the selected document。 



 

 

 

 

8.点击 Transform 按扭。 

 

现在，这两张影像都在相同的投影坐标系统(United States：Lambert Conformal Conic, meter)下并都有相同的像素大小 。

您可以将这些影像镶嵌在一起或者是保存以保留参考信息。 

2.2 高级导入教程 

高级导入（Advanced Import）功能可以导入多个影像，并且提供了有用的设置可以改变参考文件、坐标系统、彩色通道

管理、DEM方案，调整影像大小和范围甚至是镶嵌。对于按指定地理范围快速裁切大数据量的影像很有用，因为原来可能



 

 

 

需要很长的加载时间。在这个练习里，您将导入不同格式、不同大小、不同坐标系统的两景影像，然后将它们镶嵌在一

起。 

1.在 Geographic Imager面板里，点击 Advanced Import 按扭。  

2.在 Advanced Import对话框里，从格式下拉列表里选择 GeoTIFF/BigTIFF/TIFF 并点击 Browse。 

3.导航找到 Tutorial Data文件夹，选择 boston-east.tif，并且点击 Open。如果必要的话，点击 OK关闭提示设置透明度和图

层效果的信息框。 

 

这样，在导入文件列表里就显示出了 boston-east.tif 的信息，并且显示出了它的坐标系统－Massachusetts Mainland Zone 

以及影像大小 800 x 800 像素。 

4.从格式下拉列表里选择 ECW并且点击 Browse。 

5.导航找到 tutorial data文件夹，选择 boston-west.ecw，并且点击 Open。 



 

 

 

 

这样在列表里又增加了关于 boston-west.ecw的信息，并且显示出该影像没有坐标系统，它的影像大小为 650 x 650 像素。 

您要使用 Advanced Import选项使这些影像兼容，这样才能用镶嵌。 

6.在文件列表里，选择 boston-west.ecw让它高亮显示。接下来，在 Source Coordinate System框里，点击 Same As 复选

框。  

 

在坐标系统下拉列表里，只能看到 boston-east.tif，因为文件列表里除了 boston-west.ecw只有它一个。这样，在文件列表

里，boston-west.ecw的坐标系统就更新成了 Massachusetts Mainland Zone。接下来，您要通过输入重采样值将 GeoTIFF 影

像尺寸修改一下。. 

7.点击 boston-east.tif 使其高亮显示。下面，在 Image Extents框里，点击 Resample按扭打开 Resample Image对话框。 

8.将宽度修改为 650像素。保持长宽比例（Keep Aspect Ratio）选项可以确保高度也是 650。 



 

 

 

 

9.点击 OK. 

10.这样，Dimensions列的值就更新成了您刚输入的重采样大小。 

 

Image Extents框也更新成了重采样后的大小。 

 

最后，您要设置镶嵌选项以便这些文件能镶嵌在一起。 

11.在对话框的下面，点击 Mosaic all files to the destination document 复选框。 

 

boston-east.tif file显示在了列表里面，它将成为镶嵌目标文档。 

12.点击 OK完成 Advanced Import处理。 



 

 

 

 

现在，这两个影像格式可以镶嵌在一起生成一个无缝的影像了。这个操作得到的结果跟先分别打开影像，再调整坐标系统，再

修改影像大小，再生成一个镶嵌图的处理流程得到的结果是一样的。  

在 Layers 面板里，要注意根据这两景影像只生成了一个图层。想保留单个的图层，要在 Advanced Import 对话框里勾选 Keep 

source data on separate layers选项。 

2.3 高级导入 DEM 教程 

高级导入功能也可以导入 DEM文件并且对 DEM模式（schema）进行设置。在这个练习里，您还要指定坐标来对 DEM 数据进行裁

切处理。想了解关于裁切影像更多信息请参阅地理裁切教程。 

1.在 Geographic Imager面板里，点击 Advanced Import 按所扭。  

2.在 Advanced Import对话框里，从格式下拉列表里选择 USGS DEM并点击 Browse。 

3.导航找到\Tutorial Data\Mt Olympus 3D Landscape Data文件件，选择 MtOlympus.dem，并点击 Open。 



 

 

 

 

在导入文件列表里就显示出了 Mount Olympus DEM数据，并且显示其坐标系统为 NAD83 / UTM zone 10N，DEM大小为 1047 x 

1468像素。 

在列表下面的 DEM Schema框里，显示出了 schema (Yukon Water)。如果该 DEM Schema没有自动拉伸－Auto-stretched，就点

击 Specify 按扭并选择 Auto-stretched 模式。这样做可以让 DEM渐变显示，即自动拉伸到它的值。 

4.在 Image Extents框里，点击 Crop 按扭。 

5.从单位类型（Unit Type）下拉列表里选择 Geodetic，并且从坐标格式（Coordinate Format）下拉列表里选择 Decimal 

degrees。  

6.在左上角（Top-left Corner）框里，经度栏里输入-123.750，纬度栏里输入 47.790。 

7.在右下角（Bottom-right Corner）框里，经度栏里输入-123.715，纬度栏里输入 47.765。 



 

 

 

 

8.点击 OK。 

 

根据您指定的坐标裁切后，现在该 DEM的大小为 519 x 560像素(从 1047 x 1468 像素裁切得到)。DEM Schema也变成了"Crop 

auto-stretched"，说明并不是 DEM里的所有值都包括在这个 schema里。 

9.您要保存这个 DEM Schema，让它有一个合适的名称，可以看到它的范围值。 

10.在这个 DEM Schema框里，点击 Specify 按扭。 



 

 

 

11.在 Import DEM File对话框里，点击绿色的 Create New Schema 按扭。 

输入 Rocky Mountains Cropped 作为新的 schema名称，然后点击 OK。 

 

这个裁切后的 DEM数据的高程值范围是 801 米（最低）－1938米（最高）。在裁切之前，高程值范围是 496米－2429米。裁

切操作去掉了一些较高和较低范围的高程值。 

 

12.点击 OK关闭该对话框。 

在下面的文件列表里和 DEM Schema框里，可以看到这个 DEM Schema的名称更新了。 

而且高程值范围也进行了更新显示。DEM的大小也在 Image Extents 框里更新显示了。 

13.点击 OK导入此 DEM。 



 

 

 



 

 

 

 

3.影像赋参考 

3.1 影像赋参考教程 

这个练习使用的正射影像是美国印弟安纳州的 Lafayette地区的。该影像没有地理参考信息。但是为了练习需要，它有 6个绿

色的箭头，标识了您为该影像赋参考时添加的控制点的位置。 

1.在 Adobe Photoshop里，从 Tutorial Data文件夹下打开 Lafayette.jpg。 

在 Geographic Imager面板里，Reference file栏里没有指定文件，因为在影像文件夹里没有相应的参考文件。同样，在坐

标系统栏里也没有指定的坐标系统信息。 

2.在 Geographic Imager面板上，点击 Georeference 按扭。 

影像原本是 NAD83/UTM Zone 16N投影坐标系统。您可以输入世界坐标将其作为投影坐标，但是为了简单些，您可以输入 WGS 

84经纬度的大地坐标系统作为世界坐标。 

3. 在影像预览图的左边,使用导航控制进行平移缩放定位到影像左上角的绿色箭头 1 的位置。 

4. 点击 Add Point按钮并在预览图上准确点击绿色箭头末端（如果必要的话，将预览图再放大些）。 

 

这样，就在 352,489像素位置处添加了第一个控制点 Point 1。控制点表格里就多了一行。您得为 Point 1添加一个世界坐标

以创建一个控制对。放置控制点的最佳位置应该是清晰可辨的地方，如道路交叉口、建筑物拐角或者产权边界。 

5.在控制点列表里，双击 Coordinate System，WX，或者 WY单元。 

6. 选择 WGS 84 坐标系统, 然后输入： 

 Lat:40.417492 

 Long:-86.860779 



 

 

 

 

 

7.点击 OK. 

这样，表格里就有了该点的世界坐标。 

 

8.使用鼠标导航找到影像右上角的 2号绿色箭头控制点。  

9.点击 Add Point按扭并且准确点击第二个图钉末端。 

10. 在控制点表中, 为 Point 2输入如下地理坐标: 

 Lat:40.420841 

 Long:-86.839035 

 

要添加第三个和第四个控制点，您需要导入一个 CSV文件。 

11.点击 Import Additional Control Points 按扭。找到 Tutorial Data文件夹，选择 Lafayette_point3and4.csv，点击

Open。 



 

 

 

 

 

这样，就把 Point 3和 Point 4添加到列表和影像视图里了。该 CSV文件同时包括了像素坐标和世界坐标。您可以通过移动

影像视图查看第三个和第四个控制点绿色箭头。您要继续添加第五个和第六个控制点。 

 

12.给 5号绿色箭头添加一个控制点。 

13.点击在线分配世界坐标（Assign World Coordinates Online）按扭。 



 

 

 

 

Assign World Coordinates Online 对话框就打开了一个网络地图。这个功能是通过网络地图为第五个控制点来找到与之匹配

的位置坐标。  

14.要确保您从匹配点的位置（Matching Point Location）下拉列表里选择了 Point 5 (未指定－UNASSIGNED)。 

15.点击 SATELLITE 按扭切换到卫星网络地图视图下。 

16.使用其它点作为近似参考找到第 5个控制点的位置。(它在 Sagamore Pkwy路和 Kossuth St路的交叉口)。当您找到这个

地方的时候，准确点击这个位置作为世界坐标（交叉口的中心）。点击 Yes 给 Point 5分配一个世界坐标。 

 

您可以同时操作 Georeference对话框和 Assign World Coordinates Online 对话框。 



 

 

 

 

 

17.对第六个控制点（最后一个）重复上面的操作。 

 

给影像赋参考的算法（Method）默认设置为仿射变换（Affine），这种算法最少需要 3 个点。仿射变换用于给影像赋参考，一

般较高级的算法是用来对影像进行纠正。建议使用尽可能多的控制点来计算得到优质的参考面（六个或者更多控制点是比较好

的）。 

18.点击 Solve 按扭。 

这个 Solve功能会基于您指定的控制点计算得到最佳坐标系统(这就是为什么使用了 6个控制点)。这些坐标系统跟类似的综合

误差非常相似。在您自己的工程里，当使用其中一种的时候，最好是使用跟数据相匹配的坐标系统。在这种情况下，记住最初

的坐标系统是 NAD83 / UTM Zone 16N投影坐标系统。 

19.在坐标系统列表里，选择 NAD83 / UTM zone 16N 并点击 OK。 



 

 

 

 

 

这个控制点表格里有几列是每个控制点的位置误差（单位是像素或者世界单位）。 

 

为了减小误差，您可以对控制点的位置进行调整。通过查看控制点表格里的误差列来确定调整后点位精度是否有提高。另外，

使用 Validate 工具和 View Image Extents Online来确认您的参考面精度如何。 

20.使用 Validate工具来检查您的参考面精度。 

当使用 Validate工具的时候，您还可以同时操作 Georeference对话框。 

21.点击 Reference 来完成影像赋参考操作。如果出现消息框的话，点击继续对影像赋参考（Continue to reference the 

image）。 

现在，这个影像已经赋完参考了。Geographic Imager 面板上就出现了一个名称为 Lafayette.tfw 的参考文件，并且坐标系统

为 NAD83 / UTM zone 16N。默认参考文件格式为 World (tfw)。这种格式可以转换。 



 

 

 

 

 

22.想保存参考文件和影像文件的话（虽然影像自身没有修改），可以在 Adobe Photoshop主菜单里点击 File > Save。参考

文件 Lafayette.tfw也作为影像附属文件保存在同一路径下。或者，您可以使用另存为（Save As）将其存成另一种格式，包

括 TIFF (能将影像保存为 GeoTIFF)。 

3.2 快速赋参考（Quick Georeference）教程 

Quick Georeference是对影像快速的进行赋参考的方法。使用该方法有两个条件： 

 影像没有经过旋转操作(影像跟真北方向对齐)。 

 只需要两个点来给影像赋参考。但是，这些点一定不能有相同的 X/Y 像素或世界单位的坐标。（例如，在影像坐标

系和世界坐标系上，这两个点不能在相同的 X/Y轴上对齐）。 

在这个练习里，您要将一景影像快速赋到 WGS84坐标系统参考下。 

1.在 Adobe Photoshop里，找到 Tutorial Data文件夹打开 Americas_4.tif。 

这景影像是没有指定参考的。它也符合以上两个条件－没有旋转同时跟真北方向对齐。 

2.在 Geographic Imager面板里点击 Georeference 按扭。  

3.在 Georeferencing对话框里，点击影像视图左边的 Add Control Point 按扭。点击影像视图上的任意位置来添加一个点。 

这样，在控制点列表里就添加了 Point 1。您要调整一下像素坐标(PX和 PY)并且添加世界坐标(WX和 WY)。 

4.双击 PX单元，输入 599。双击 PY单元，输入 0。 



 

 

 

 

 

5.双击 Coordinate System，WX或 WY单元。 

6.选择 WGS 84 坐标系统。在 Lat栏里输入 35.917，在 Long栏里输入-50.064，然后点击 OK。 

 

在控制点列表里就显示出了更新后的坐标系统。 



 

 

 

 

 

7.在影像视图里添加第二个控制点。这次，使用像素坐标： PX = 0, PY = 456；并且使用世界坐标：Lat = 6.731, Long = -

88.417。 

 

现在，两个控制点对就准备好了。下面您就可以使用 Quick Georeference功能。 

8.点击 Quick Georeference 按扭并且选择 By Two Reference Points (North/South aligned)选项。 

这样，在控制点列表和影像视图里就添加了另一个控制点。它的世界坐标是基于已有的这两个控制点对计算得到的。因为对影

像赋参考至少需要 3个控制点。接下来，您可以指定影像坐标系统。 

 

9.点击 Image Coordinate System框里的 Specify 链接。 

10.在 Choose Coordinate System对话框里，点击[No Coordinate System Specified]链接。 



 

 

 

 

11.在 Specify Source Coordinate System对话框里，展开 CoordinateSystems > Geodetic > World目录，选择 WGS 84 坐

标系统，点击 OK。 

 

10. 点击 OK关闭 Choose Coordinate System对话框。 

 

这样，影像的坐标系统就更新了。现在就已经准备好了，可以对影像完成赋参考操作。 

 

11. 点击 Reference 就完成了影像赋参考操作。 



 

 

 

 

 

至此，这个文档就成功的赋上了地理参考信息。 

3.3 影像纠正（Rectification）教程 

通过多个控制点来 Rectification或者"坐标拉伸（rubber sheeting）”会改变一个栅格影像的几何结构。根据不同的几

何变换（参考）算法，正确的纠正处理能够减少影像上的几何变形，对其进行重新调整并且缩放，这样，影像的线型就跟

指定的地理坐标系统轴平行了。 

在这个练习里，您将处理一张坐标投影未知的历史地图，对其进行赋参考并纠正到 WGS84坐标系统下。该图有经纬网交叉线，

选为控制点的位置比较好。您需要指定影像上均匀分布的足够数量的控制点。纠正影像要使用二次多项式的转换（Quadratic 

transformation）方法。 

1.在 Adobe Photoshop里，找到 Tutorials Data文件夹，打开 Dakotas.jpg。 

注意，这个影像是没有参考信息的。接下来，您要引入已有的控制点，将它们中的一些移到准确的位置，然后添加两个控制点

完成赋参考操作。 

2.在 Geographic Imager里，点击 Georeference 按扭。   



 

 

 

 

 

接下来，您要添加一些控制点。 

3.点击 Import Additional Control Points 按扭，找到 dakotas_gcp.csv，然后点击 Open将里面的控制点都添加到

Georeference对话框里。 

 

在影像视图和控制点列表里就出现了 6个控制点。为了方便练习，其中的 4个控制点已经放到了正确的位置上。接下来，您需

要将其它两个控制点（Point 1和 Point 3）移到正确的位置。注意，Point 1的 X&Y 世界坐标是-104.049和 49.000 度。 

4.有影像视图 里，放大到 Point 1 (影像左上角)的位置。点击 Select Points 按扭，然后点击 Point 1将其拖到 49°线跟

第一个垂直线交叉处（见下图）。 



 

 

 

 

 

现在 Point 1 就移到了正确的位置，大约-104.000和 49.000度。 

在参考列表里，注意 Point 3 的世界坐标为-97.000和 49.000度。您也要将它移到正确的位置上。 

5.在影像视图里，放大找到 Point 3 (影像的右上角)。将其移到 49°线跟 97°线交叉的地方。 

 

Point 3现在就在正确的位置上了，大约-97.000和 49.000 度。接下来，您要添加另外两个地面控制点，然后选择合适的校正

方法。 

6.点击 Add Point 按扭。漫游到地图的顶部中间位置。点击 101°线和 49°线交叉处。(如果必要的话，使用 Select Points 

工具来将其移动到正确的位置。)在控制点列表上，双击 WX或 WY单元。 

7.在 Edit Location对话框里，Lat栏里输入 49，Long 栏里输入-101，然后点击 OK。 

 

Point 7 就有了它的世界坐标。 



 

 

 

 

 

8.在 Add Point 按扭仍然激活的情况下，漫游到地图的底部中间位置，点击 101°线和 43°线交叉处。在 Point 8那行双击

WX或 WY单元。Lat栏输入世界坐标 43 ，Long栏输入世界坐标-101。点击 OK。 

 

有了这 8个控制点对，您就可以使用高级的算法来纠正该地图了。  

 拥有足够数量的控制点并不能保证得到好的纠正结果，只是一个比较合理的纠正方法；

反复试验法可能更合适，能得到最佳纠正效果。 

接下来，您需要指定 WGS 84 作为影像的坐标系统，然后选择一种纠正方法来完成纠正。 

9.点击 Image Coordinate System框里的 Specify 链接。 

10.在 Choose Coordinate System对话框，点击[No Coordinate System Specified]链接。 

11.在 Specify Source Coordinate System对话框，展开 CoordinateSystems > Geodetic > World目录，选择 WGS 84 坐标

系统，点击 OK。 



 

 

 

 

 

12.点击 OK关闭 Choose Coordinate System对话框。 

 

13.点击 Rectify using 复选框，选择 Quadratic Polynomial (min 6 points)。 

Quadratic Polynomial方法使用至少 6个地面控制点来计算得到比较好的参考面。像素和世界坐标误差会达到最小 (水平滚

动参考列表可以看到误差值) 。使用 WGS 84作为影像坐标系统是因为经纬度线作为参考比较容易识别。采用二次多项式纠正

算法和 WGS84 坐标系统有助于将此地图纠正成一个实用的带有地理参考的地图。 

14.点击 OK。当弹出命令窗口时点击 Proceed to rectify the image。 



 

 

 

 

 

15.点击 Transform 完成影像纠正。 

 

这样，就使用 Transform工具完成了对影像的纠正。转换后，影像就纠正到了 WGS 84 地理坐标系下。注意，地图上的经纬度

线是直的。想验证检查此纠正精度，可以使用 Georeference 对话框里的 Validate工具。 



 

 

 

 

 



 

 

 

 

4.影像镶嵌 

数据供应商和政府机构一般会提供很多类型的栅格数据，包括正射影像和 DEM文件。这些数据中的很多都是免费的。通常，这

些栅格数据都是分过幅的，很多时候需要将这些数据镶嵌合并生成一个单独的无缝覆盖的整个区域的数据文件。使用

Geographic Imager您就可以将这些影像镶嵌生成一个单独的合并后的空间影像。 

Mosaic功能可以将输入的多个带有地理参考的影像合并生成一个单独的带有地理参考的合成影像，包括 DEM文件。镶嵌处理

所需的可用文件可以是不同坐标系统的、不同像素大小的、不同旋转角度的。这些文件都会被实时转换跟目标镶嵌文件的属性

一致。当进行镶嵌时，还可以使用高级转换选项来指定坐标系统、重采样像素大小或者旋转角度。 

 

将 4景影像镶嵌在一起，目标文件是投影坐标系统。镶嵌结果就是跟目标文件一样的投影坐标系统。. 

 当目标文件有旋转角度时，是不支持镶嵌过程中进行转换的。要想镶嵌到带有旋转的目标文

件里的话，待镶嵌的文件必须跟目标文件有相同的投影坐标系统、像素大小和旋转角度。 

4.1 镶嵌教程 

在这个练习里，您要将带有不同坐标系统的几个影像镶嵌在一起生成一个带有投影坐标系统的影像。 

1.在 Adobe Photoshop里，找到\Tutorial Data\Americas文件夹，打开 Americas_1.tif， Americas_2.tif，

Americas_3.tif 和 Americas_4.tif 文件。 

2.在 Americas_4.tif文件里，在 Geographic Imager面板里点击 Reference file框的 Specify 链接。选择

Americas_4_reference.tfw，点击 Open。 



 

 

 

 

 

这样就加载了参考文件，但是 Americas_4 文件还是需要坐标系统信息。 

3.点击 Geographic Imager 下 Coordinate System 框的 Specify 链接，点击 Same As 复选框，从下拉列表里选择

Americas_1.tif (WGS 84)。 

 

4.点击 OK。 

5.确认 Americas_2.tif为活动文档，在 Geographic Imager面板上点击 Mosaic 按扭。 



 

 

 

 

 

注意，Americas_2.tif是 Lambert Conformal Conic投影坐标系统。它是目标镶嵌文件，也就是说其它影像会统一转换到与

之相同的投影坐标系统下然后再镶嵌在一起。用于镶嵌的文件可以是不同的坐标系统、不同的像素大小或者旋转角度，都可以

无须转换直接进行镶嵌。这些影像将以目标文件的坐标系统和像素大小为标准。 

当目标文件有旋转角度时，是不支持镶嵌过程中进行转换的。要想镶嵌到带有旋转的目标文

件里的话，待镶嵌的文件必须跟目标文件有相同的投影坐标系统、像素大小和旋转角度。 

在镶嵌对话框里会显示出待镶嵌的文件。接下来，您要指定要镶嵌的文件。 

5.点击 Transfer All 按扭，将所有待镶嵌文件移到镶嵌列表里。 



 

 

 

 

 

您可以使用 Advanced Transformation Options 来对文件进行重采样，设置条带大小并且保留原始图层或者是将图层合并。

在这个练习里，我们选择默认设置。 

6.点击 OK开始镶嵌处理。 

 



 

 

 

 

这样，就在 Americas_2.tif 文件里完成了镶嵌，投影坐标系统为 Lambert Conformal Conic。 

 

检查 Adobe Photoshop Layers面板。注意，其它文件都镶嵌合并到了 Americas_2.tif里。所有的图层都完好无损的保留了下

来，因为您设置成了 Keep source data on separate layers选项。您可以自行设置图层是否可见或者是将图层锁定。这样可

以使影像编辑操作更加灵活。想拼合影像的话，选择 Layer > Flatten Image。  



 

 

 

 

5.影像分幅 

分幅（Tile）功能是将单个的影像切分成多个影像。对影像进行分幅可采用两种方式：图幅数量或者图幅大小。如果原始影像

是有地理参考的，那么分幅后的影像都是附有参考文件的（或者影像自身内部有参考信息的格式，如 GeoTIFF, BigTIFF或者

TIFF）。分幅后的图幅可以按顺序命名，也可以按行列号或者角点坐标命名。 

 

一景影像切分为 9个相同大小的图幅。 

5.1 分幅教程 

在这个练习里，您要将一景影像切分成多个图幅。 

1.在 Adobe Photoshop里，找到\Tutorial Data\Americas文件夹，打开 Americas_mosaic.tif。  

2.在 Geographic Imager面板里，点击 Tile 按扭。  

3.在 Tile对话框里，选择 By Number of Tiles选项，在 Horizontal和 Vertical文本框里都输入 3。 



 

 

 

 

 

在 Destination框里，就自动显示图幅总数为 9。 

4.在 Overlap 框里，在 Horizontal和 Vertical文本框里都输入 5。要确保在 Units下拉列表里选择 Pixels。  

 

这样，裁切的图幅间会有 5 个像素的重叠。 

5.从 Naming 下拉列表里选择 Separate Row/Column Numbers。 

每个图幅的名称里将包括原始影像的名称+自身的行列编号。 

6.从 Format下拉列表里选择 GeoTIFF/BigTIFF/TIFF。 

 

7.点击 OK。 



 

 

 

 

8.为这些新图幅设置一个保存路径。在这种情况下，使用默认文件名(Americas_mosaic_1_1.tif)，点击 Save。 

 

9.当出现 TIFF Options对话框时，点击 OK接受默认设置。 

 

这些设置会应用到随后生成的所有图幅文件（这种情况是 9个图幅）。如果您需要对这些图幅进行优化或压缩处理的话，可以

灵活使用这些设置。 

10.完成分幅处理后，找到目标路径去查看这些图幅。 



 

 

 

 

 

之前设置的行列号命名规则就应用到了这些文件名里：图幅 America_mosaic_1_1.tif属于第一行第一列；

America_mosaic_1_2.tif是第一行第二列；America_mosaic_1_3.tif是在第一行第三列，如此类推。 



 

 

 

 

6.影像裁切 

裁切（GeoCrop）功能是对带有地理参考的影像基于裁切范围进行裁切。可以通过以下几种方式来设定裁切范围： 

 手动划定 

 基于像素 

 基于地理或投影坐标 

 基于已有文件 

 基于一种坐标系统范围线 

 基于邻近距离法 

 基于一个矢量范围文件 

当指定裁切参数的时候，GeoCrop对话框里的预览图会实时更新显示预裁切范围。裁切后的地理空间影像仍然保留着参考信

息。Advanced Import功能可以使用 GeoCrop功能导入大景影像而无须先打开。带图层的影像（镶嵌）裁切后仍然会保留其原

有的图层结构和 alpha通道。 

 

GeoCrop功能可以基于像素坐标或者大地/投影坐标来进行裁切处理。 



 

 

 

 

6.1 GeoCrop 教程 

GeoCrop功能是基于定义的裁切范围对带有参考的影像进行裁切。 

1.在 Adobe Photoshop里，找到\Tutorial Data\Americas文件夹，打开 Americas_1.tif。 

2.在 Geographic Imager里，点击 GeoCrop 按扭。 

3.从 Unit 下拉列表里选择 Geodetic，并且从 Coordinate Format下拉列表里选择 Decimal degrees。 

4.在 Top-left Corner框里，Long栏里输入-122.50，Lat栏里输入 62.50。 

5.在 Bottom-right Corner栏里，Long栏里输入-91.50，Lat栏里输入 39.50。 

 

 



 

 

 

 

左上角和右下角坐标就构成了裁切区域，显示为红色虚线框。该功能类似于 Adobe Photoshop的 Crop工具，不同之外在于它

能通过精确的地理坐标来确定裁切范围。 

6.想手动修改裁切范围，点击虚线框的四角或者边缘拖动即可重新定义大小。 

 

这样，四角坐标就发生了改变。这是根据 AOI来快速裁切影像的一种方法。 

 

7.点击 OK完成裁切操作。 



 

 

 

 

 

这样，影像就按 GeoCrop 对话框里指定的范围裁切好了。也可以用 Adobe Photoshop 的 Crop 工具来裁切影像。Geographic 

Imager 会尊重用 Crop 工具来进行裁切并且也保留空间参考信息。如果您希望空间影像有特定大小，这个 Crop Tool 工具是挺

有用的，因为它可以设置尺寸和分辨率 (W x H x 分辨率)。 



 

 

 

 

7.地形晕渲 DEMs 

地形晕渲是一种将 DEM以自然生动的方式呈现出来的方法。  

地形晕渲功能可以将着色方案和晕渲效果应用到支持的数字高程数据（例如，DEM,SRTM等等）上。着色方案共有两种：使用

一种颜色地图或者一个重叠影像。应用颜色地图也有两种方法：对影像的 DEM schema进行梯度拉伸或者使用一种预定义的颜

色地图。当应用颜色地图、重叠影像或者晕渲效果设置的话，预览图会实时更新显示这些设置得到的晕渲效果。 

 

通过动画显示添加地形晕渲前后的效果。 

7.1 地形晕渲教程 

导入 DEM 文件 

当 Adobe Photoshop 里打开高程数据的时候，Geographic Imager 会自动检测到。Import DEM File对话框会自动打开，您可

以在这里指定一个 DEM schema和其它设置。 

1.在 Adobe Photoshop里，在\Tutorial Data\Americas路径下找到 Tutorial Data文件夹并打开 Namu Water.dem。 

2在 Import DEM file对话框里，点击 Create New Schema 按扭。 



 

 

 

 

 

这样，就打开了 Edit DEM Schema对话框。该 Schema Name已经根据数据文件的名称自动显示。也根据 DEM数据的高程范围自

动显示出了高程最大值和最小值。 

 

3.由于这些值都是在范围内，因此不用修改。点击 OK。 

 

4.现在，Select Schema栏里就显示了 DEM 数据的范围值。 

5.在 Import DEM file对话框里，点击 Advanced按扭。 



 

 

 

 

 

在 Display as transparent pixels列表里，-32767.00值是一个预定义的值，代表没有数据。这个值无法删除，对所有的

DEM文件都是一样的。要想将某个高程值设为透明像素，在列表里键入高程值即可。 

6.点击 Add new value按扭。双击<new value> 输入 0。  

 



 

 

 

 

7.点击 OK关闭 Advanced DEM Schema Settings。点击 OK接受 Import DEM file对话框的设置完成数据导入。 

 

以上选择将 DEM的高程范围定义成了 Adobe Photoshop灰度图颜色空间，显示了最高的对比度。根据前面 Advanced DEM 

Schema里的设置，图上有一片透明区域，此区域的高程值为 0。 

此 DEM里，高程值 0代表水体。现在这片水域是透明的，我们可以很方便地创建一个背景图层，用一种不同的颜色来体现水域

（记住，这里颜色空间是灰度图）。在下一个练习里，您将使用晕渲功能对这个高程数据图层应用一种渐变地图，还要创建一

个背景。 

8.将文档保持为打开状态，后面的晕渲教程会用到。 

地形晕渲 

地形晕渲是利用 DEM数据给影像赋样式。您可以使用预定义的或者定制的颜色地图快速创建一个渐变地图调整图层。 

1.继续对前面导入的 Namu Water.dem 进行操作。 

2.在 Geographic Imager面板里，点击 Terrain Shader 按扭。 

3.点击 Colorization Schema复选框来启动它的选项。选择 Apply Color Map选项并自动应用列表里的第一个颜色地图 (或最

后一个颜色地图) 。如果下图跟您对话框里显示的不一样，那么就选择 World颜色地图。 



 

 

 

 

 

Create Single Layer选项默认是勾选的，它可以创建一个渐变地图调整图层。不勾选这个选项的话软件会为每个图层都创建

一个渐变地图调整图层。Use Continuous Color选项默认也是勾选的，它能确保颜色渐变处理时颜色间的过渡会自然平滑而

不会有看起来不连续的情况。  

4.在 Colorization Schema框里点击 Import Color Map From File 按扭。 

(颜色地图右边的第三个按扭)。从 Tutorial Data文件夹里选择 Colour Ramp Examples.grd。 

5.从 Color Map下拉列表里选择 Elevation 3 并点击 Import。 



 

 

 

 

 

6.从 Color Ramp下拉列表里选择 Elevation 3，并且点击 Edit Selected Color Map 按扭。 

 

Edit Color Map对话框显示了高程信息是如何在颜色地图里被着色的。悬停在颜色渐变图上查看高程值跟选定的颜色渐变方案

是如何对应的。 

7.在 Color Stop 1 (在列表顶部)上右击该表项的颜色样板，并点击 Edit Color Stop。 或者，在 color ramp上点击 color 

chip slider。 

8.在 Select Color for Color Stop对话框里，输入新颜色值 Red：204，Green：198，Blue：181。  



 

 

 

 

 

9.点击 OK关闭颜色对话框。再次点击 OK关闭 Edit Color Map对话框。 

 



 

 

 

 

10. 点击 Apply Shaded Relief 复选框。将角度改成 40 并将 Intensity调整为 35。 

 

11. 点击 OK。 

 

这样，您自定义的颜色渐变效果就应用到了这个 DEM里。注意，在 Layers面板里是保留了原始 DEM（和背景）的。晕渲地貌

和颜色地图图层都在这些图层的上面。 

想要添加一个背景，只需要创建一个新的图层并将其放在图层列表最下面即可。 

12. 创建一个新图层并将其重新命名为 Background。使用 Adobe Photoshop PaintBucket工具并且将这个图层填充成蓝色 

(R: 100, G: 130, B: 175)。 



 

 

 

 

 



 

 

 

8.导出空间影像 

保存带有空间参考的影像文件 

当保存 Geographic Imager里带的格式的影像时，软件内部会自动保存其参考信息。内部自带参考的格式有：GeoTIFF, 

BigTIFF, DEM TIFF, Geospatial PDF, ERDAS IMAGINE Raster, ECW, MrSID 和 NITF。当处理这些格式的影像时，使用 Adobe 

Photoshop的 Save命令来保存该影像并更新其参考文件。 

在 Adobe Photoshop Save As 对话框里，GeoTIFF直接显示为 TIFF (*.TIF, *.TIFF)， 

geospatial PDF显示为 Photoshop PDF (*.PDF, *.PDP)。根据初始影像格式，某些格式类型在

保存的时候可能没有。 

当将影像保存为任意 Adobe Photoshop格式时，会自动生成一个外部参考文件。例如，当把一个带有地理参考的影像保存成一

个非地理空间格式（如 JPEG）时，Geographic Imager会为其创建一个外部参考文件(如 World File)。想要存成任意支持的

影像格式，要使用 Adobe Photoshop Save As命令并且在 Format下拉列表里选择正确的格式。  

在 Save As时，每种支持的格式都可能有其自己 Adobe options对话框。例如，当存成 GeoTIFF格式时，会出现 TIFF 

Options对话框。当存成 Photoshop PDF时，会出现 Save Adobe PDF对话框。对于 BigTIFF/DEM TIFF, ECW, DEM, USGS DEM, 

ASCII GRID和 MrSID 格式，会出现下图这样的对话框。  

 

例如： 当导出成 ArcInfo ASCII Grid 格式时，会出现这个 Options对话框。 

当保存一个非空间影像格式（如 JPEG或 PNG）时，同时会生成一个外部参考文件。例如，文件名为 VancouverCity.jpg

的影像会有一个名为 VancouverCity.tfw (World参考文件格式)的参考文件。在保存时，Geographic Imager会基于最新

的转换设置来自动更新相关的参考文件。 

注意：在执行了一些 Geographic Imager的功能后再保存影像的时候，Geographic Imager会

自动更新参考文件。在这个过程中，原始的参考文件就被覆盖了。为了避免原始影像遭到破坏，

可以使用 Save As命令，创建一个新文件名和文件位置，而不要选择 Save命令。 



 

 

 

 当存成 BigTIFF 格式时，超过 4 个波段的影像是不能使用 JPEG 影像压缩选项来进行保存的。

对于 RGB或灰度 BigTIFF影像，使用 JPEG 影像压缩选项只支持 8 bit RGB, RGBK 或 grayscale 

波段数少于 4 个。当使用脚本存成 BigTIFF 时，要注意这个问题，因为可能会用到 JPEG 影像压

缩选项(这样做会导致错误的结果)。 

当存成带有 JPG压缩的 BigTIFF格式时，跟存成带有 JPG 压缩的 TIFF格式相比，文件大小可能

会有很大的不同。 影像质量都是差不多的。 

当勾选 Alpha Channel 复选框来保存一个 DEM 格式的数据时，结果时并没有保存上 alpha 

channels。数字高程模型如 DEM, BIL和 ASC 是不支持 alpha channels的。 

 保存一个带有浮动精度选项的 USGS DEM格式时，会生成不被一些二代 DEM应用程序支持的文

件(高程值可能被误读成整型)。 

导出坐标系统数据 

通过 Geographic Imager 面板选项菜单，定义的坐标系统可以导出成一个 WKT Definition File (.wkt)或者 Esri Projection 

file (.prj) 。从面板选项菜单里选择 Coordinate System打开 Export 对话框。  

一些没有保存坐标系统信息的参考文件(如 world文件.tfw)可以从一个 WKT Definition File或者 Esri Projection文件里

得到信息。这些文件里有导出的坐标系统的所有参数。 

当存成一个参考文件时，有一些投影是不支持的，无法保存该坐标系统。强烈建议也导出一个坐标系统文件。 

导出一个参考文件 

带有地理参考的影像里面定义的坐标系统可以通过 Geographic Imager 面板选项菜单导出成一个参考文件。通过选项菜单找

到 Export Reference File，并选择以下参考文件格式来导出: 

参考文件格式 参考文件扩展名 

Blue Marble Reference File 

.rsf 

ER Mapper .ers 

GeoTIFF* .tif 



 

 

 

MapInfo TAB File 

.tab 

World Files  
.tfw, .tifw, .wld, .jgw, .pgw, 

.sdw, .eww, .blw, .dmw, .bpw 

* 当前文档为 TIFF的时候，只有 GeoTIFF选项。将一个参考文件导出为 GeoTIFF是另一种把非地理空间的 TIFF转成 GeoTIFF

的方法。 

导出功能也可以用于修改一个影像参考文件格式。地理参考信息应该先导成想要的参考文件格式，然后点击 Geographic 

Imager面板里的 Reference File link 来指定新的参考。 

 如果一个影像的参考在导出后改变了，只当前的参考文件会被更新；之前导出的参考文件不会被删除或者更新。只能用

当前的参考文件，旧的就不能用了。在重新打开影像的时候要记住这一点。 

 

9.导出教程 

9.1 导出成网络瓦片（Web Tiles）教程 

Export Web Tiles功能是指生成可以用于在线地图发布用途的影像图幅。随着瓦片的生成会同时生成一个 HTML文件。使用网

络瓦片导出选项（Web Tile Export Options）对话框来调整图幅选项。 

1.在 Adobe Photoshop时，从 Tutorial Data文件夹里打开 boston-east.tif。 

2.在 Geographic Imager面板里，点击 Export Web Tiles 按扭。 

在影像被导出成网络瓦片之前，它必须得是 WGS 84/PseudoMercator坐标系统。这个 Export Web Tiles功能将临时把该影像

从 Massachusetts Mainland Zone转换成 WGS 84/ Pseudo-Mercator，这样才能兼容。 

3.点击转换该影像并且继续导出（Transform the image and proceed with the export）。 



 

 

 

 

4.在 Export Document to Web Tiles对话框里，从 Map Provider下拉列表里选择 Google Maps。 

5.在 Name栏里，重命名为 Boston。 

6.对于 Folder，点击 Browse，在 Tutorial Data文件夹里创建一个名称为 WebTiles 的文件夹。 

 

7.在 Zoom Level选项卡里，将 Maximum zoom选成 Level 17 - 1.19 meters/pixel 并且将缩放级别修改为 17。 



 

 

 

 

总共生成了有 90个网络图幅。最小缩放值是 Level 1 - 78272 meters/pixel，基本上是一个小比例尺图。 

8.点击 Options选项卡。从 Image format下拉列表里选择 PNG 并且将 Compression改成 0。 

 

Compression值为 0可以确保导出高质量的影像。您可以将 Google Maps选项卡的设置选为默认(您也可以试验一下这些设置

会对网络地图有什么影响。)。 

9.点击 Advanced 按扭。选择一个 World 格式的参考文件，然后点击 OK。 

 

您需要创建一个参考文件，但是如果在其它地方要用这些网络图幅的话，可能会用的到。 

10.点击 OK开始导出处理。 

11.完成网络图幅导出处理后，找到您指定的导出文件夹。 



 

 

 

 

在导出文件夹下，就创建了几个新的文件夹(Z1到 Z17)。这些文件夹里是组成网络瓦片的 PNG影像，代表了您指定的 17个缩

放级别。而且在文件夹里还包括跟每个图幅影像相关联的 TFW参考文件。 

12.双击 Boston.html 在网络浏览器里打开它。 

 



 

 

 

该 Boston.html文件就包含了这个网络地图（该地图里有从 Geographic Imager导入的所有图幅）。  

9.2 导出并上传到 PDF Maps 教程 

Export to PDF Maps功能是指生成一个可以直接上传到 PDF Maps Store-PDF地图商店（它是一个安装在 IOS、Android和 

Windows手机上的 PDF Maps app应用程序内部的商店）里的地图包。 使用这个功能上传地图是把它们放到 PDF Maps Store

上的 Prepare for Review时。要上传，您需要有一个 PDF Maps商店的供应商账户。 

1.在 Adobe Photoshop里，从 Tutorial Data文件夹里打开 boston-east.tif。 

2.在 File菜单里，找到 Export > Export to PDF Maps. 

 

这样就出现了 Export to PDF Maps对话框。您可以指定一个不同的导出文件夹并且在这里对其进行设置。勾选所有的选项，

就会把该影像转换到索引颜色模式，导出完成后启动上传到 PDF Maps（Upload to PDF Maps）对话框，并且打开文件浏览器

到指定的导出文件夹。  

3.点击 OK。 



 

 

 

 

该导出文件夹显示了这个地图包文件。当上传到 PDF Maps Store时，文件夹里的所有的文件都是需要的。当在您的设备上加

载时，只需要 ZIP文件。 

还会出现 Upload to PDF Maps对话框。要想上传地图，您需要登录到自己的 PDF Maps Store供应商账号。 

4.在 Upload to PDF Maps对话框里，点击 Login按扭。 

5.输入您的账号邮箱和密码，然后点击 Login。 

 

6.在 Upload to PDF Maps对话框里，点击 Load maps from folder 按扭。 

7.在 Load From Folder对话框里，选择导出文件夹(在本练习里，是\Geographic Imager\AvenzaPDF\boston-east)，然后点

击 OK。 



 

 

 

 

这个地图包就被添加到了 Upload to PDF Maps 对话框的表格里，并且有其自己的地图信息。 

 

8.双击 Description单元格。在 Edit "Description"对话框的 Description文本框里输入描述信息，然后点击 OK。 

 

这样，完成了 Description，该地图在就有了简短的文字描述。 

9.点击 Edit All 按扭。 

这个 Edit Maps 对话框允许您在正确的位置编辑所有的地图描述信息。如果有多个地图，您可以使用导航控制来移动到前一个

或后一个地图上。 



 

 

 

 

10. 完成对其它地图的编辑，如下面所示，然后点击 OK。 

 



 

 

 

在这里编辑这些地图描述信息跟在 PDF Maps Store 供应商网站上编辑是一样的。您可以在这里编辑也可以在那里编辑。不管

怎样，地图描述信息应该准确并且完整，这样用户才能在 PDF Maps Store 里很容易的搜索到您的地图。 

 

11.点击 Upload 按扭。  

 

Uploaded列里图标的变化表示这个地图已经上传成功。 

12. 在 Upload to PDF Maps对话框里点击 Go to PDF Maps Store 链接或者是在一个网络浏览器里打开

https://mapstore.avenza.com/vendor/login/。用您的账户登录就能看到您上传的地图。 

https://mapstore.avenza.com/vendor/login/


 

 

 

 

在 Maps页面，您会看到自己上传的地图。刚上传的地图放在 Prepare 状态里，意味着该地图仍在准备审核。当您输入了所有

的地图描述信息时，您可以上传地图用于审核。当您的地图处于审核状态时，它的状态就变成了审核中（In Review）。 PDF 

Maps团队会详细的对这些地图进行审核，当审核通过后，就会把它放到等候（On Hold）队列里，准备销售（Ready for 

Sale）状态。这时，您就可以将该地图设置成 For Sale 状态，在 PDF Maps Store里销售了。  



 

 

 

10. Geographic Imager 自动批处理教程 

Adobe Photoshop 的操作（Actions）和脚本（scripts）在 Geographic Imager 里是支持的，并且可以使用 Javascript 和

actions（但是，目前 Visual Basic和 Applescript是不支持的）来实现自动化批处理。 

Actions和 scripts可以使重复的任务实现自动化，为费时的手动任务提供了极大的便利。脚本对操作有一个好处，因为条件

逻辑能够写进它们里面，这样就可以基于当前任务来做出决策。脚本也包括多个应用程序。另一个好处就是，当操作只使用一

个文件位置的绝对路径时，它可以使用可变的路径。由于脚本是用 Javascript 来写的，所以它们能跨平台兼容并且在不同的

计算机上工作，而操作有时不能在不同的系统上工作。 

脚本可以在任意文本编辑器（如 TextEdit 和 Notepad）里查看和编辑。理想情况下，脚本应该使用 Adobe Photoshop提供的

Adobe ExtendScript Toolkit来创建和运行。这个应用程序提供了很多调试工具，有助于创建脚本。也可以用 Adobe 

Photoshop安装的 ScriptListener 插件来创建脚本。 

操作会记录在一个日志文件里面，用于生成一个脚本。Adobe Photoshop CS6 /CC 2014 没有安装脚本语言文件夹。想了解更

多信息，请访问 Adobe Photoshop脚本语言网站：http://www.adobe.com/devnet/photoshop/ scripting.html。 

支持的/不支持的功能 

在操作或者脚本里使用的 Adobe Photoshop功能将保留地理参考信息。注意，由于 Adobe Photoshop API的限制，有一些功能

还不支持。 

支持的功能 

 ExtendScript Toolkit 

 Run script using File > Scripts > Browse 

 Run script by double-clicking script 

 Run script by drag-and-drop into Adobe Photoshop 

 Run action using Action Panel 

 Image Processor 

 Create Droplet  

 Actions that run a script or another action 

 File > Automate > Batch, where the Source drop-down list is set as Folder or Open Files. 

 File > Automate > Batch, where the Destination drop-down list is set as None or Save and Close. 

 Scripts that run another script or action 

 Actions that run a script or action that run another script or action 

 Scripts that run a script or action that run another script or action 

http://www.adobe.com/devnet/photoshop/scripting.html
http://www.adobe.com/devnet/photoshop/scripting.html


 

 

 

不支持的功能 

 Adobe Photoshop closed when using automate tools 

 Insert menu item from Action panel 

 Script Events Manager 

 File > Automate > Batch, where the Destination drop-down list is set as Folder. 

 Specifying new folder names and new file names are unsupported. 

 File > Automate > Batch, where the Source drop-down list is set as Advanced Import. The action is not 

completed because Advanced Import parameters have to be set manually. 

10.1 创建操作和脚本 

使用 ScriptListener插件的操作或脚本是无法检测到 Geographic Imager面板按扭、链接和选项菜单的。  

当记录操作或脚本时，可以从 File > Automate menu使用以下功能： 

  

Geographic Imager: Quick Rectify 当需要快速纠正一景影像时使用。 

Geographic Imager: Channel Management 当需要修改影像波段设置时使用。 

Geographic Imager: Export Coordinate 

System 
当需要导出一景影像的坐标系统时使用。 

Geographic Imager: Export Reference File 当需要对一景影像导出参考文件时使用。 

Geographic Imager: GeoCrop  当需要对一景影像进行裁切处理时使用。 

Geographic Imager: Georeference  当需要进行赋参考时使用。 

Geographic Imager: Mosaic  当需要进行影像镶嵌时使用。 

Geographic Imager: Quick Save To Format 

当需要创建一个 DEM TIFF, USGS DEM, ECW, ERDAS 

IMAGINE Raster, geospatial PDF, GeoTIFF, MrSID 和 

NITF时使用。 



 

 

 

Geographic Imager: Show Panel 

显示或隐藏 Geographic Imager面板 

Geographic Imager: Specify Coordinate 

System 
当需要为一景影像指定坐标系统时使用。 

Geographic Imager: Specify DEM Schema 当需要为一景影像指定一种 DEM晕渲方案时使用。 

Geographic Imager: Specify Reference 

File 
当需要为一景影像指定参考文件时使用。 

Geographic Imager: Terrain Shader 当需要对一景影像应用颜色或晕渲时使用。 

Geographic Imager: Tiling 当需要对一景影像进行分幅时使用。 

Geographic Imager: Transform 当需要进行坐标系统转换时使用。 

当记录操作或脚本时，可以从 File > Export menu使用以下功能： 

  

Export to PDF Maps 当需要将地图包导出到 PDF Maps时使用。 

Export to Web Tiles 当需要导出网络瓦片时使用。 

10.2 使用脚本来实现 Geographic Imager 功能的批处理 

Adobe Photoshop主要有两种方法来创建脚本。第一种方法需要对 Adobe Photoshop 目标模型和基本的 JavaScript 编程技巧

比较熟悉。对于构建的脚本，方便的使用 GeographicImager.jsxinc文件里提供的功能即可。第二种方法是使用 Adobe 

ScriptListener 插件（记录了用户执行的操作）来创建脚本，将结果存成一个准备执行的文本脚本文件。在允许快速生成一

个执行一系列任务的脚本的同时，这个自动生成的脚本多少有些难于修改和维护，因为它包括了所有的硬编码参数（如文件路

径）。同时也很难读取和组织，因为它通过使用每个 Adobe Photoshop或 Geographic Imager要求的参数直接填充所谓的

Adobe Photoshop描述语直接调用了 Adobe Photoshop 的低级功能。如果您选择使用 Script Listener来记录您的脚本，您可

能想仔细查看 GeographicImager.jsxinc来了解传给 Geographic Imager命令的具体参数。 



 

 

 

 关于脚本 Adobe Photoshop 功能，可参阅 Adobe 脚本文档、Adobe 论坛 (http:// 

forums.adobe.com) 以及第三方网站来获取有用的信息。 

Geographic Imager安装了一个名为样例脚本（Sample Scripts）的目录，在： 

Windows 7/8 (32-bit and 64-bit) 

C:\Users\Public\Documents\Avenza\Geographic Imager\Help and Tutorial Data \Tutorial Data\Sample Scripts 

Mac 

/Applications/Avenza/Geographic Imager/Geographic Imager Plug-in/Help and Tutorial Data/Tutorial Data/Sample 

Scripts 

这个 Sample Scripts文件夹包括： 

ScriptExamples.jsx 
提供了关于所有 Geographic Imager脚本功能和样例的信

息。 

ScriptBatchProcessingExample.jsx 包括了一个批处理的样例脚本。 

3D Overlay Script.jsx 生成带有可选重叠影像的 3D DEM的一个脚本。 

Mt Olympus.jsx 跟 Geographic Imager教程一起使用。 

Batch export to PDF Maps.jsx 用于将多个文件导成 PDF地图。 

 

 两个单独的文件夹，StartupRegistrationScripts和 IncludeScripts，里面包括的是启动

Geographic Imager操作和脚本语言的脚本。这些文件夹及其内容不能重命名或者删除，否则

Geographic Imager 将无法支持。如果重命名或者删除了，可以通过改回原来的名称或者重新安

装 Geographic Imager 来恢复。 

 触发 Geographic Imager对话框（如保存一个非兼容的文档）的脚本化 Adobe Photoshop操

作将总是假定为“showerrors-only”模式。 

http://forums.adobe.com/
http://forums.adobe.com/
http://forums.adobe.com/
http://forums.adobe.com/


 

 

 

 在执行程序所支持的功能的过程中弹出的 Geographic Imager对话框，子对话框或者警告应

该尊重传递给它们的任何选项。只有明确可以通过脚本参数（还有如果从一个操作运行而被显示

为操作参数的）来编写脚本的选项将被记录。所有其它的选项将假定按默认选择来设置。这里是

可以通过勾选"Don’t show again"选项来修改的。  

 由于 Adobe Photoshop API的限制，当用脚本或者操作来打开一个地理空间 PDF文件时，

Geographic Imager不能从它里面自动读取参考信息。 

 当在一个脚本里使用 DEM schema名称时，该名称是不支持 Unicode字符的。 

 生成 DEM schema是无法记录在 Adobe ScriptListener或使用样例脚本来记录的。任何的

DEM schema都得先于使用自动处理前生成。 

 

 

 

 

  




