nfernational

ISR Rectifier

Application Note AN-1110

Embedded 8051 Application Development for
IRMCF/K300 Series Motor Control IC

By Ali Husain, International Rectifier

Table of Contents

Page
INTRODUCTION ... 2
PUIPOSE ... e 2
= To [0 (=T g L= 1 3
GETTING STARTED GUIDE ......coovviiiiiiiiiiiiiiiiiieeieeieeeeeeeeeeeeeeeeeeeeeeeee 3
SOftWAre SEIUP ..o 4
Hardware SETUP .....oovvie e 5
Hardware and Software Startup ..........oeuveeiiiiiieiiiieiiiii e 6
Making changes to the sample code ........cccooeeevviviiiiiiiiiieeeeee, 7
SAMPLE CODE STRUCTURE .......cuutiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiienes 7
ClOCK FIrEQUENCY ....coeiiieiiiiiiie et 8
T 0 | ] (=] £ 8
Files and Functions of Sample Code.........cccceeeeiiiiiiiiiiiiinneeeeee. 10
CONTROLLING A MOTOR....ccttitiiiiiiieitieeieeeeeeeeeeeeeeeeeeeeeeeeseeeeeeeseeeeeeees 12
Drive Configuration.............couuuuiiiiiie e 12
MCE Header File ... 13
MOLOr FUNCHONS ... 13
ADVANCED IMPLEMENTATION ..ot 14
Downloading 8051 code to EEPROM........ccoooeiiiiiiiiiiiiiiiieeeeee 15
Restoring the original 8051 code............cceiiiieiiiiiieiicieee e, 16
Troubleshooting...........uuiiiii e 16
APPENDIX: Keil uVision2 Project OptioNS..........ccoovveiiiiiiiiineeeeeeeeeeiinens 18

This application note describes the 8051 sample code supplied with the
IRMCS3041 Reference Design Kit. It includes descriptions of the code to
transfer data between the 8051 and MCE cores along with drivers for the
communication ports and other 8051 peripheral blocks.
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INTRODUCTION

The 8051 microprocessor, included in the IRMCF/K300 series of motion control
ICs, can be used to implement a large variety of control and protection functions
for motor control applications. The instruction set and basic operation of the
IRMCF/K300 Series 8051 microprocessor is consistent with the standard Intel
8051 processor. A number of peripheral devices and special functions have been
added to customize the operation for motor control applications.

The IRMCF/K300 series ICs contain two processors: an 8051 processor and the
Motion Control Engine (MCE). The 8051 and MCE interact through a shared
RAM, accessible by both processors. The MCE is designed specifically to
implement motor control loops, process feedback signals, and calculate PWM
switching signals. The 8051 mediates between external control signals (such as
the front panel of a washing machine) and the MCE, which ultimately produces
the signals that operate the motor.

The 8051 software application controls and monitors the operation of the MCE
through a read/write register interface. The 8051 “developer” application used
with the MCEDesigner tool does this in a simple lock-step manner:
MCEDesigner specifies each register to be read or written individually, and the
8051 software performs only those operations as they are requested. An 8051
user application, on the other hand, would typically perform entire sequences of
operations automatically or in response to simple input commands such as “start”
and “stop.”

Purpose

The purpose of this application note is to describe the implementation of 8051
microprocessor control for use in the IRMCF300 and IRMCK300 series of motion
control ICs. This document covers required initializations, settings and functions
for 8051 control of the IC. Some examples and sample code are presented.
This application note assumes that the user has experience with embedding
software programming.

The sample code and examples given here are intended to allow the designer to
create a control interface to replace MCEDesigner once the application
development has been completed. One of the main tasks is to recreate
MCEDesigner functions in the 8051 code. After code development and testing
with the IRMCF version of the IC, the embedded 8051 code is intended to be
written to the ROM of the IRMCK300 series ICs.
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Requirements
The following software and hardware is required for 8051 application code
development:
1. FS2 ISA-M8051EW Debugger with Keil uVision driver (FS2 debug pod)
2. Keil PK51 Professional Developers Kit (Keil uVision2)

Using Keil uVision2, the developer can write the control program in the C
programming language and then compile it into machine code for download to
the IRMCF300 Series IC for testing. uVision2 provides a simulation mode so that
portions of the program that are not hardware-dependent can be tested without
downloading to the actual IC. The sample source code provided was developed
with Keil uVision2.

The Keil compiler used for 8051 software development generates code that uses
big endian byte ordering to store 16-bit and 32-bit values in memory. The MCE
is a 16-bit processor and uses little endian byte ordering for data storage. The
smallest unit of data storage on the MCE processor is 16 bits (it cannot access a
single byte in memory). The shared RAM used to exchange information between
the 8051 and MCE processors is 8-bit addressable to the 8051, but 16-bit
addressable to the MCE. Functions to correctly read and write the shared RAM
are included in the sample code. These functions correctly swap bytes when
necessary, and lock out bus accesses to prevent data being read by one
processor while it is still being written by the other.

In addition, the circuit board containing the IRMCF3XX IC should contain the
appropriate connectors, drivers, and isolators to interface with the FS2 hardware.
If IR’s IRMCS3041 Reference Design Board is used, the appropriate circuits are
built in, with proper isolation for the FS2 hardware connection. If any other
hardware is used, follow the instructions in the warning below.

Warning!

When connecting the FS2 debug pod to the circuit board, the FS2

hardware can be damaged by the high voltage on the board if

appropriate isolation is not used. The problem arises because the

DC bus minus (GND) is not at the same potential as earth (or
wall) ground. For this reason, if proper isolation is not used, it is recommended
that the board be powered by a DC power supply with isolated ground when
using the FS2 hardware.

GETTING STARTED GUIDE

This section explains how to get started with 8051 application software
development using the FS2 debug pod, Keil uVision tools, and the IRMCF300
Series IC. Though this guide applies to a general hardware configuration, often
the IRMCS3041 Reference Design Board is referenced as a specific case.
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Software Setup

Keil uVision2:

1. Start Keil uVision2. Choose Project>Open Project and open the file
IRSamples.Uv2, which is included with the sample code. In the “Project
Workspace” window, click on the topmost folder, IRSamples.

Choose Project->Options for Target ‘IRSamples’. Select the Debug tab.

Click the radio button “Use:” and set the field to its right to Fs2/Keil ISA-

M8051EW Driver, as shown in Figure 1 below. If this option does not

appear in the list, the FS2 software has not been installed properly.

4. Click Setting and check that the Settings are: TckRate: 62500 and Tvcc
Threshold: 2500. All the other settings under “Options for Target
‘IRSamples’ should be configured automatically. The Appendix to this
application note lists all the options that should be configured.

5. Press “OK” in the Settings window and then “OK” in Options window.

W

COptions for Target 'IRsamples’ @
Device | Taget| Output | Listing | ©51 | 251 | BLS1 Log B Misc Debug | Utiiies |
" Use Simulator settings (& Use: [Fez/Kei 1A MBDSTEW Diiver <] [ Settings | )
¥ Load Application at Startup [v Gao Hll rmain] rd ication at Startup [v Go Hll oo
Initialization File: Initizlization File:
Fiestore Debug Session Settings Restare Debug Session Settings
[v Breakpoints v Toolbox [+ Breakpoints v Toolbox
IV watchpoints & PA [ Watchpoints
v Memory Display Iv Memory Display
CPU DLL: Pararmeter: Drriveer DLL: Pararneter:
58051.0LL 58051.0LL
Dialog DLL: Parameter: Dialog DLL: Parameter:
DPST.OLL -1 |TF'5‘I.DLL |-p51
ak | Cahicel | Defaults |

Figure 1: Debug Options window for a uVision2 project

HyperTerminal:

1. Open HyperTerminal (from Windows, choose Start->Programs
—>Accessories>Communications>HyperTerminal).

2. If the New Connection window does not automatically appear, select
File->New Connection. Choose a name and icon for your connection and
press “OK.”

3. Under “Connect Using,” select the appropriate COM port. This will likely be
the same port that MCEDesigner uses to communicate with the control
board. Press “OK” and the Properties window will open. Set the “Bits per
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Second” field to 57600, “Flow control” to None and verify the rest of the

settings as shown below in Figure 2.

J COMS5 Properties W
Paort Settings
Bitz per second; |5?EUD M
[ ata bits: |8 M
Farity: |Nnne M
Stop hits: |‘I M
Flaws contral: |Nnne M
[ QK ] ’ Cancel ] Apply

Figure 2: HyperTerminal connection Properties window

Hardware Setup

First Silicon Soluﬁons

Figure 3: FS2 _debug pod connected to IRMCS3041 Reference Design Board

Connect the UART interface to the computer where you have installed Keil
uVision2 and MCEDesigner. On the IRMCS3041, this is achieved using an RS-
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232 (serial) cable from the control board to the PC. Also, connect the FS2 debug

pod to the control board. On the IRMCS3041, the FS2 Pod interfaces to the

control IC through the connector J11, as shown in Figure 3 below. If the
IRMCS3041 Reference Board is not used, follow the warning below.

Warning!

When connecting the FS2 debug pod to the circuit board, the FS2

hardware can be damaged by the high voltage on the board if

appropriate isolation is not used. The problem arises because the

DC bus minus (GND) is not at the same potential as earth (or
wall) ground. For this reason, if proper isolation is not used, it is recommended
that the board be powered by a DC power supply with isolated ground when
using the FS2 hardware.

Hardware and Software Start-up
To properly start up the board and software, follow these steps:
1. Apply power to the controller board, and then turn on the FS2 pod.
2. Start Keil uVision2. Choose Project>Open Project and open the file
IRSamples.Uv2.
3. Choose Debug-> Start/Stop Debug Session. The FS2 Console should come
up briefly and a status bar in the lower left corner will display the progress in
loading the 8051 code to RAM, shown in Figure 4 below.

File Edit Wiew Project Debug Flash Peripherals Tools SYCS Window Help

Q=EHE & Ghylitdet  ~[ A
B & @ DE & &l m

MEe&TN | R ARVEEE A

Project Waorkspace = Mermory = .
Register | Walue | Address
= Regs ## This function disables intterrupts before
1] 0=00 ## It assunes interrupts are ENABLED on entrv.
al 000 int rFifoGetChar { unsigned char * pChar )
2 0x00
s o0 if ( IrFifoCount )
! “ return 0y
4 000 disable_isr ( SIOINTHUHM 3:
i} 0=00 #pChar = rzFifo [ rFifoTail ]:
6 0=00 rFifoTail = { rFifoTail + 1 ) & RFIFO_MODULC
7 [0 ——rFifoCount
i enable_i=r ( SIOINTHNUH ):
Sys return ( 1 )
a =00 T
b 0x00
=p 000
dptr 00000
PC § 0x0000
o psw 000 A
=tr PLON 1
| | =fr TCOH | if { lrFifoCount )
- return { 0 };
E) Fies _“ j—rJ ssble_isr { SIOINTNUM };
L ﬁl L4 @ Az = VUFEFF\ r % Fﬁ'rin 1
*[Serial mumber 00578 ]| ame | value |

f=s2.inl section: m805lew
Load "C:»~Program Files “iMOTION®

>
ARM ASEIGH BreakDisable

A—"'ITPI %, Build )\Enmmand A Find in
@_ 31%

Figure 4: uVision window during 8051 program load.

tput Window:

[T »[»]Locals f watch #1 } watch #2 J Cal
R
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4. Choose Debug—>Go.

5. Start HyperTerminal and open the connection set up above. The motor can
be controlled by commands sent through the HyperTerminal. (See section
Motor Functions for commands.)

6. To exit from Keil after testing, choose Debug—>Stop. Then Debug->
Start/Stop Debug Session. The program may be terminated at this time.

Making changes to the sample code

1. To make changes to the sample code, copy all the files of the sample code
into a new directory.

2. Select all the files and right-click to select “Properties.” De-select “Read-
only” and click “OK.”

3. Open the new project and modify files as desired. Save files by choosing
Files—> Save All.

4. To rebuild the machine code, choose Project->Rebuild all target files. The
compiler will generate a new .hex file.

5. Follow the instructions in Hardware and Software Start-up to test the
modified program in hardware. If the hardware is still powered on after
testing a previous revision of your program, you can start at Step 3. It isn’t
necessary to power the hardware off and back on before redownloading.

SAMPLE CODE STRUCTURE

The main functions that an embedded 8051 application performs are to configure
the MCE with the proper drive parameters and to start, stop, and regulate the
speed of the motor. These are the same functions performed by MCEDesigner;
the difference is that the “intelligence” is transferred from the host application
(MCEDesigner) to the embedded 8051 application. Any MCEDesigner function
(a pre-defined series of register operations), including timing delays, can be
implemented directly in the 8051 application so that it can control the motor
independently or with simple external commands.

The 8051 controls and monitors the MCE by reading and writing interface
registers. The registers are described in the next section. The general steps that
the embedded 8051 application must perform are:
1. Initialize the hardware—set clock frequency, initialize counters and timers,
etc.
2. Start the MCE—verify that a valid MCE program has been loaded and
initialize MCE program counter
3. Configure the drive—write drive parameters to MCE registers for the desired
motor
4. Start, stop, change direction, change speed—keep track of current state in
order to correctly implement command (e.g. don’t change direction if motor
iS running).
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5. Monitor for faults—periodic interrupts handle external commands, reset the
Watchdog timer, check for faults/errors and shut down drive if necessary.

Clock Frequency

The MCE code must set-up the phase-locked loop to generate the SYSCLK
frequency by writing to the SFRs PLLFO and PLLF1. The sample code already
contains instructions to select between 32, 50, 64 and 128 MHz for the clock
frequency. Simply uncomment the appropriate #define statement in timer.h.

Based on clock frequency the code should set the proper baud rate, timer
initialization and reset values. These also are set up correctly when the clock
frequency is selected in timer.h. However, some drive parameters are also
dependent on the clock frequency. The user should regenerate the drive
parameters from the “Parameter Configurator” using the new clock rate. See
section Drive Configuration below.

Registers
There are several types of registers, listed and described below.

1. Special Function Registers (SFRs)—SFRs can only be accessed by the
8051 microprocessor. Only a subset of the SFRs is described in this
Application Note. A complete list and description of the SFRs can be found
in the IRMCx3xx Users Guide. The SFRs can be used to:

¢ Initialize and modify processor registers
Configure and read I/O ports
Set the clock frequency
Configure, initialize and reset timers
Configure the UART
Enable analog features such as op-amps
Enter and exit low-power modes
Configure and enable interrupts
Read faults and status
Configure and use I°C/SPI serial interface
Read and write the fixed MCE registers
Read and write the user-defined MCE registers

Since SFRs can only be accessed by the 8051microprocessor, writing to
these registers is relatively simple. They are defined in irmcx3xx.h using a
special “sfr” keyword. Each SFR is assigned a name that corresponds to its
memory address. In the sample code, the convention is that SFR names
are in all capitals. They can be written and read using the name, as with
any other variable. Below is an example of the SFR assignments that must
be made to set the clock frequency to 50MHz.

PLLFO = 0x62; // set clock speed to 50 MHz

PLLF1 = OxCO;
PLLF2 = 1; /I switch to PLL clock
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PLLF3 =0;

2. Fixed MCE Registers (FREGs)—The FREGs are accessible by both the
MCE and the 8051 microprocessor. The MCE accesses the FREGs
through the Motion Peripheral Blocks, and may modify a subset of them
every PWM cycle. The 8051 microprocessor accesses the FREGs through
a set of dedicated SFRs. Most FREGs only need to be configured once
before running the motor, which can be done by the 8051 application.
Additionally, the 8051 application may write to FREGSs to start and stop the
motor, or adjust parameters due to varying operating conditions.

Each FREG is defined in reglf.h with an alias that begins with “FREG_" and
corresponds to its memory offset. The functions DoRtIRd and DoRtIWr in
the sample code are provided to read and write these registers through the
dedicated SFRs. It is recommended that these functions be used without
modification as the specific sequence of operations is critical for correct
operation. Below is an example of writing the number “0” to Fixed MCE
Register pwmctrl_1.

DoRtIWr ( FREG_pwmctrl_1, 0);

3. User-defined MCE Registers (RAM_REGs)—These registers are also
accessible by both processors. However, in contrast to the FREGs, the
RAM_REGs are not fixed in memory. The RAM_REGs are defined in the
MCE Simulink design, and are assigned RAM addresses by the MCE
Compiler. The compiler outputs a header file that should be incorporated
into the 8051 code (detailed in section Drive Configuration). The name
assigned to the register has the format:

<Simulink Sub-model>_<register name in Simulink>

Although RAM_REGs are directly addressable to the 8051 in shared RAM,
another dedicated set of SFRs are used to access them in a controlled
fashion that prevents data corruption. (This is necessary because the MCE
accesses the registers as a single 16-bit operation while the 8051 requires
two 8-bit operations.) The functions DoRamWr and DoRamRd are
provided in the sample code to read and write RAM_REGs through the
dedicated SFRs. Below is an example of setting the Motorl DC Bus Over-
voltage Level to 172.

DoRamWr ( Motorl_DcBusOvlevel, 172);
Note: In MCEDesigner, the FREGs can be distinguished from the RAM_REGs

by looking at the “Access” column in the right side of the Motorl window. To see
this column, click on “Register Structure Definitions” on the left side of the Motorl
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window. The “Access” column will show Write or Read, optionally followed by a
special character, listed below:

* (asterisk) Fixed MCE Register (FREG)

No character  User-defined MCE Register (RAM_REG)

X Obsolete Register

+ Local 8051 register. These registers are currently
unused.

Files and Functions of Sample Code
The sample code is composed of several C source files, which divide the
functions into groups according to their use. The .c files are:

1. main.c — Execution begins here. The main function calls each of the
samples. The last sample function, MotorCtrl, does not return.

2. regif.c — This file contains functions to read and write 16-bit registers in
shared RAM with guaranteed coherency using 8051 SFRs. See
RtlIRegs.SRC for the low-level implementation of the FREG interface and
Coherent.SRC for an implementation of the RAM_REG interface. Examples
of calls to the register interface functions can be found in MotorCitrl.c.

3. EepromlI2C.c — This file contains sample code to read and write the
EEPROM using the 12C interface.

4. Timer.c — This file contains a function that initializes timer 1 to generate
interrupts at 2 msec intervals. A global variable "systicks" is incremented on
each interrupt and the FREG_FaultFlags register is checked for a fault
condition. The interrupt service routine also resets the Watchdog timer.
The Watchdog timer must be reset periodically; otherwise the IC as a whole
will reset. Timer setup varies based on the clock rate, which is set in
timer.h.

5. MceBoot.c — This file contains functions to initialize the MCE using code
that has been programmed to EEPROM by the MCEDesigner tool. It
assumes that the automatic boot process has copied the MCE code from
EEPROM to shared RAM and an "MCE Info" structure from EEPROM to a
fixed location in 8051 program RAM.

The function StartMce first copies the "MCE Info" structure from 8051
program RAM to a location in data RAM and verifies the validation field in
the structure. If the validation field is incorrect, the entire structure is
assumed to be invalid and the MCE is not initialized. Otherwise, the MCE
Info structure provides the starting load address in RAM and the MCE
execution address. The StartMce function uses this information to zero the
MCE data area preceding the start of the MCE program. The function
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doMceBoot is called to initialize the MCE special registers and begin MCE
execution.

6. asyncDriver.c — This file contains functions to set up the UART and read
and write data using FIFO (first-in-first-out) buffers. For parts that support
two UARTS, the code can be compiled for UART1 by commenting out line
20, which defines USE_UARTO. The following functions are included in the
file:

siolsr - This is the UART interrupt service routine, which handles transmit
and receive interrupts. Received characters are placed in the receive FIFO.
Characters to be transmitted are taken from the transmit FIFO.

siolnit - This function initializes the transmit and receive data structures and
the SFRs that control the UART.

flushTx - Initializes the transmit FIFO.
flushRx - Initializes the receive FIFO.

setBaudRate - Inializes the baud rate SFR for 57,600 bps, based on the
default clock rate of 64 MHz.

putChar_ - This function is called from a higher level (such as the
MotorCtrl function) to transmit a character. If the transmitter is currently
busy, it adds the character to the transmit FIFO. If no transmission is
already in progress, it writes the character directly to the UART transmit
buffer. The function returns 0 if the transmit FIFO is full (character cannot be
accepted for transmission); or 1 if successful.

getChar_ - This function is called from a higher level to read a received
character from the receive FIFO. It returns O if the receive FIFO is empty
(no character available) or 1 if successful.

xFifoRoom - Called from putChar_ to check the status of the transmit
FIFO. Returns 0 if the transmit FIFO is full; 1 otherwise.

xFifoPutChar - Called from putChar_ to add a character to the transmit
FIFO. Returns O if the transmit FIFO is full; 1 if the character was
successfully added to the FIFO.

xFifoGetChar - Called from siolsr to get the oldest character from the

transmit FIFO. Returns O if the transmit FIFO is empty; 1 if a character is
removed from the FIFO.
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rFifoRoom - Called from siolsr to check the status of the receive FIFO.

Returns 0 if the FIFO is full; 1 if the received character was successfully
added to the FIFO.

rFifoPutChar - Called from siolsr to add a character to the receive FIFO.
Returns O if the receive FIFO is full; 1 if the character was successfully
added to the FIFO.

rFifoGetChar - Called from getChar_ to get the oldest character from the
receive FIFO. Returns 0 if the receive FIFO is empty; 1 if a character is
removed from the FIFO.

IMPORTANT NOTE: The transmit and receive FIFOs are manipulated from
both the interrupt level and the "task™ (non-interrupt) level. For this reason,
it is very important to ensure that UART interrupts are disabled while
characters are added to and removed from the FIFOs at the task level.

7. MotorCtrl.c — This file contains a simple example of motor drive
configuration and control. It reads character commands from the serial port
using the functions provided by the UART driver. You can use a
HyperTerminal (or equivalent) connection to send commands and read
responses. A list of supported commands and their descriptions can be
found in the section Motor Operation.

The function MotorCitrl checks that the MCE versions defined in regif.c and
loaded from EEPROM match, before allowing motor control operations. For
more information, see section MCE Header File.

8. RtIRegs.SRC — Assembly-language functions to read and write RTL
registers through the SFR interface.

9. Coherent.SRC — Assembly-language functions to read and write shared
RAM registers using SFR registers for coherent data transfer.

10.utils.c — Utility functions to enable and disable a particular interrupt,
identified by the interrupt number, as defined at the beginning of the file.

CONTROLLING A MOTOR

Drive Configuration

After power-up, the motor will not run properly until the MCE has been configured
with the correct parameter settings. These drive parameter values are generated
using the “Parameter Configurator” (Excel spreadsheet). The second tab of the
spreadsheet contains the correctly scaled values for the MCE registers. These
values should replace the sample values defined in MotorCtrl.h. This process
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can be somewhat automated by exporting the sheet in text format and then
adding “#define” at the start of each line.

MCE Header File

The MCE code is generated when the Simulink model file is compiled. The
compiler also produces a header file (.h) which contains 1) definitions of user-
defined MCE registers, 2) register map structures for addressing of the user-
defined MCE registers, and 3) product and version identification. This code
should replace the samples at the top of reglf.c and reglf.h. In reglf.h, replace
the section titled “COMPILER GENERATED DEFINITIONS” with the
corresponding section in the MCE Compiler header file. Similarly, in regif.c,
replace the section titled “COMPILER GENERATED INITIALIZATIONS” with the
corresponding code in the header file.

Note that the MCE design ID and version number of the header file must match
that of the MCE code loaded from the EEPROM for correct operation. If the
Simulink model is changed, then a new header file must be created during
compilation and added to the code as described in the paragraph above.

The sample code is configured to correctly write to the RAM_REGs of the
IRMCS3041 Reference Design Kit and has the proper drive parameters to run
the Golden Age GK6040-6AC31 motor.

Motor Functions

The sample code treats the motor as a state machine, with three states:
DRIVE_IDLE, DRIVE_RUN and DRIVE_FAULT. The function MotorCtrl takes
input commands from the serial port and passes valid ones to MotorSeq. Based
on the current motor state, MotorSeq calls appropriate functions to implement
the command or returns an error indicating that the command was invalid. If an
invalid command is entered, an X is returned to the HyperTerminal display.
Listed below are the commands supported from the function MotorCtrl, with
explanations of their operation.

Corc

Configure motor drive and clear faults. The command character is echoed (sent)
back to the host computer on the serial port when configuration is complete. If
the motor is running, the command is ignored and an 'X' is sent instead of the
command character. See section Drive Configuration above.

+

Set forward direction. The command character is echoed when the operation is
complete. If the motor is running or in a fault condition, the command is ignored
and 'X' is sent instead.
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Set reverse direction. The command character is echoed when the operation is
complete. If the motor is running or in a fault condition, the command is ignored
and 'X' is sent instead.

Forf

Clear fault condition. The command character is echoed when the operation is
complete. If the drive is not in a fault condition, the command is ignored and 'X'
iS sent instead.

Gorg

Run motor. The motor is placed in run state and turns in the configured direction
at a low speed. The command character is echoed when the operation is
complete. If the motor is already running or in a fault condition, the command is
ignored and 'X' is sent instead.

Sors

Stop motor. The motor is stopped and the command character is echoed when
the operation is complete. If the motor is already stopped or in a fault condition,
the command is ignored and 'X' is sent instead.

Rorr

Set motor speed. This is a multi-character command. The command character
must be followed by exactly four decimal digits (O - 9) defining the target speed in
rotor RPM. If the motor is not running or the requested speed is out of range for
the motor (according to the value of define Mtr_Max_Speed) the command is
ignored and 'X' is echoed. Otherwise, the operation is performed after all four
digits have been received, at which point the command character only is echoed.
If a character other than a digit is received, an 'X' is echoed and the command is
aborted.

?

Get motor speed. The current speed is read and converted to a single decimal
digit (O - 9), where each digit represents 10% of the total speed range (O -
Mtr_Max_Speed in rotor RPM). The digit is echoed rather than the command
character. The get speed command is always valid regardless of the current
state.

ADVANCED IMPLEMENTATION

The 8051 code can be used to implement more complex motor control
functions than those described above. For example, a washing machine “wash
cycle” requires that the motor accelerate rapidly in one direction, stop, and
accelerate rapidly in the other direction. This could be implemented in such a
way that the number of rotations is dependant on the whether the soil setting is
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low, medium, or high. Other operations that can be implemented include catch
spin and auto-rebalance.

Note that a command interface other than the UART may be used. For example,
to receive commands from the digital I1/O pins, modify MotorCtrl so that it
monitors the state of the SFRs corresponding to the appropriate pins and then
calls MotorSeq as needed.

Once the designer has set certain variables, such as the clock rate, these
variables could be stored in a configuration area of the EEPROM.

Downloading 8051 code to EEPROM

Once the 8051 application code has been fully tested using the FS2 Pod and Keil
uVision, the code may be downloaded to the EEPROM for stand-alone testing.
To do so, follow the steps below:

—Load Boot
 MCE to Rab anly [T StartMCE
{* MCE and 8051 to EEPROM
= Mo Load

—Filez

MCE IC:\F‘rugram Files%MOTIOM WM CEDezsigner RMC Browse, . |

2051 IE:HF’rugram Files\itMOTIOMN W CE Designertirmck, Browse. .. |
Cancel |

Figure 5: Load Target in MCEDesigner

1. Power down the controller board, then the FS2 debug Pod. Disconnect the
FS2 Pod from the controller board.

2. Power up the board and start MCEDesigner. Open an .irc file for your
controller board.

3. Click on the System window and then select Tools->Load Target. The Load
Target window is shown in Figure 5 above.

4. Select “MCE and 8051 to EEPROM.” Choose the appropriate MCE
program and, for the 8051 program, the .hex file created by uVision2.

5. When the download is complete (about two minutes), power down the
controller board and wait for the COM to go Down.

6. Power up the board, and the COM should stay Down. Close MCEDesigner
to release the COM port.

7. Start HyperTerminal (or other UART communication program) and verify
that motor control functions operate correctly.
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Restoring the original 8051 code

After stand-alone testing, the user may want to restore the original 8051 code to
the EEPROM so that application development can be continued with
MCEDesigner. To do so, follow the steps below:

1. Power down all equipment. Connect the computer and FS2 Pod to the
controller board.

2. Power up the FS2 Pod, then the controller board.

3. In uVision2, open the project corresponding to the MCEDesigner 8051 code

(e.g. IRMCx341Lib.Uv2). Choose Debug-> Start/Stop Debug Session. Wait

for the program to load. Then select Debug—->Go.

Open MCEDesigner and COM should come Up (green).

Click on the System window and then select Tools—>Load Target.

Select “MCE and 8051 to EEPROM.” Choose the appropriate MCE

program and, for the 8051 program, the .hex file corresponding to the

original code (e.g., IRMCx341Lib.hex).

7. When the download is complete (about two minutes), power down the
controller board and wait for the COM to go Inactive. Stop the debugger
and end the debug session. Turn off and disconnect the FS2 Pod.

8. Power up the board, and COM should come Up once again. The system is
now ready to take commands from MCEDesigner.

oo b

Troubleshooting
When a debug Session is started, the message “***error122: AGDI: memory read
failed” appears in the Output Window.
— Check that the FS2 debug pod is connected to the parallel port and is
turned on.
— Under Project->Options for Target ‘IRSamples’, click on the Debug tab
and then the Settings button and verify that the Comm Port setting is Lptl
(or the correct one for your PC.)

No characters echoed in HyperTerminal:

— Check that the FS2 debug pod is properly connected to hardware and
turned on.

— Under Project->Options for Target ‘IRSamples’, click on the Debug tab
and verify that “Use:” is set to Fs2/Keil ISA-M8051EW Driver. Check that
the Settings are: TckRate: 62500 and Tvcc Threshold : 2500.

— Check that the computer running HyperTerminal is connected (by serial
cable) to the hardware. Also, verify that HyperTerminal is using the
correct port with the correct communication options as described earlier in
this document (Software Setup). The COM port should be the same one
that MCEDesigner uses.
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LED does not change from red to blinking green after the drive is configured (c or
C in HyperTerminal) (for IRMCS3041)
— Check that DC bus voltage is within range and not causing a fault.

LED changes from red to blinking green (for IRMCS3041) after the drive is
configured, but the motor does not turn when commanded.
— Check that the correct drive parameters are entered into MotorControl.h
— Check that the MCE is properly started—Set a break point in MCEBoot.c
to see whether doMceBoot is called. If not, the Mcelnfo structure may be
incorrect, or the memory address, RomMcelnfo may be incorrect.
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APPENDIX

Keil uVision Project Options

These are the options that should be set under Project->Options for
Target ‘IRSamples’. The uVision2 project file (IRsamples.Uv2) is shipped with all
options set as shown below.

Device

Options for Target ‘IRsamples’

Device | Target | Output| Listing| C51 | 451 | BLS1 Locate | BLS1 Misc | Debug | Utiiies |

Dratabase: | J

“Wendar  Mentor Graphics Co.
Device: MB0S1EW ™ Use Entended Linker [Lx51] instead of BLS1
Family: MCS-51 r

+ e Honeywell -~ 8051 based CMOS Microcontroller with High-5 peedoare,
+ @ Hyrix Semiconductar - |32140 lines, 2 Timers/Counters, 14 Intermupts/4 priority levels,
: e Hyundsi upto 8 DPTRz, JTAG interface,
. E4 KB ROM, 256 Bytes on-chip Rk, B4 KB Ext. RAM
+ & Infineon

+ @ InnoaSIC

+ @ Intel

+ & (55

+ e [GER

= % Mentor Graphics Co.
[ Ma051
[ Ma051EW
[ Ma0sTw

[ mMe0s2
<. hirranac ud]
£ | *

Ok | Cancel Defaults

Target
Options for Target "IRsamples’

Device Target | Quiput | Listing| C51 | 451 | BLS1 Locats | BLS1 Misc | Debug | Utiiies |

Mentar Graphics Co. MB05TEW

stal (MHz): (120 [v Use On-chip ROM [0x0-0=FFFF)
Mermory Model: | Large: wariables in <DATA ﬂ
Code Rom Size:; |Large: E4K. program j [v Use On-chip #Rak [020-0:FFFF)
Operating system: |N0ne ﬂ

I Use muliple DPTR registers

Qff-chip Code memany Qff-chip*data memaony
Start: Size: Start: Size:

E prom ,—,— Fiam ,— l—
E prom ,—,— Fiam ,— l—
Eprom ,—,— Fiam l— I—

[ Code Banking Start: End: r

Barks: l—_| Bark Area: ,— I— N
(]4 | Cancel | Diefaults
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Output

PPLICATION NOTE

Options for Target "IRsamples’

Device | Target Output | Listing| C51 | 451

| Select Folder for Objects... |

' Create Executable: SRsamples

[+ Debug Information

I Browse Information

| BLS1 Locate | BLS1 Misc | Debug | Utiities |

Mame of Executable: ||H samples

I Meme32K Hesfile

W Create HEX File HEX Fomat: |HE:-80

" Create Librany: MRzamples. LIB

After Make

I¥ Beep when Complete

I Start Debugging

[~

[ Create Batch File

[~ Run User Program $#1: |

Browse. ..

I~ Fun User Program #2: |

_Browse.. |
Browse. ..

Cancel Defaults

Listing

Options for Target "IRsamples’

| Select Folder for Ligtings... |

Iv C Compiler Listing: A" lst

v Conditional [~ Symbals
I CPreprocessor Listing: i
v Assembler Listing: .5 lst

v Conditional v Symbols

I¥ Linker Listing: SIBsamples.mS1
I+ Memory Map

Device | Target| Output Listing | C51 | 451 | BL5T Locate | BL5T Misc| Debug | Utites |

[+ Public Symbols

[+ Local Syrmbols

Page Width: 1204@ Page Length: |65 _I;I

[ Hinclude Files [~ Azsembly Code

Tab Space: ,_—J

| | Crass Reference

Macros: |Final expansion only

¥ Line Numbers [ Crass Reference

I¥ Comment Records [v Generated Symbols

v Library Spmbols

Ok

Cancel Defaults

www.irf.com
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C51
Options for Target "IRsamples” E]

Device | Target | Output | Lising €51 | 451 | BLST Locate | BLST Misc | Debug | Utiites |

Preprocessor Symbols

Defire: ||
Undefine: |

Code Optirmization

Wwiarnings: |\-\-"aminglevel2 ﬂ
Lewel: | 9 Carron Block Subroutings ﬂ )
Bitz to round for float compare: |3 -
Emphasis: |Favor speed - I Global Register Coloring
Iv Interupt vectors at address: |0=0000

=

I Dor't use absolute register accesses

I Keep variables in order

[v Enable ANS| integer promation rules

Include
Paths | J
Mg |
Contrals
Compiler | LARGE OFTIMIZE [9.5PEED) BROWSE DEEUG OBJECTEXTEND

caottral
string

oK | Cancel Defaults

A51
Options for Target 'IRsamples’

Device | Tamget | Qutput | Listing| C51 451 | BLS1 Locate | BLST Misc | Detua | Utiities |

Conditional assembly control Symbals

Set: ||
Resst: |
Macra processor Special Function Registers
v
d sk W Define B51 SFR Names
[~ MPL

Include
Paths | E
Misc |
Controlz
Aszsembler  |SET [LARGE] DEBUG EP

control
string

0K | Cancel Defaults
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BL51 Locate

Options for Target 'IRsamples’ W

Device | Target | Output| Listing | C51 | 451 BLST Locate | BLST Misc | Debua | Utiies |

I Use Memary Layout from Target Dialog
Code Range: |E&<DDDD-E&<5FFF
Space  Base Segments: Xdata Range: IEMFBDU-EMFFFF
Code: I
Xdata I
Pdata: I
Preceds: I
Eit | |
D ata: I I
|data: I I
Stack: I
Linker |70 "IRsamples” m
contiel | RAMSIZE(256)
ztihg M
ak I Cahcel Drefauilts
BL51 Misc
Options for Target ‘IRsamples’ W
Device | Target | Output| Listing| C51 | 61 | BLS1 Locate BLS1 Misc | Debug | Utiiies |
—Warnings
Dizable ‘W arning Mumbers: I
I usze linker contral file:
Create... Browse,.. Edi...
Ovwerlay
Misc
controls
Linker |70 "IRsamples" h]
contral - |RAMSIZE (256)
shring M
0K I Cancel Defaults
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Debug
Options for Target ‘IRsamples’
Device | Taiget | Output | Listing | C51 | 451 | BLS1 Locate | BLST Misc Debug | Uriites |
™ Use Simulatar Settings || © Use: |Fs2/Keil IS4MB0S1EW Driver w|  Settings
¥ Load &pplication at Startup ¥ Go il mainf) Iv Load Application at Startup v Gao il main(]
Initialization File: Initialization File:
Restore Debug Session Settings Restore Debug Session Settings

Iv Breakpoints v Toolbox I¥ Breakpoints v Toolbox

Iv “watchpoints & P& I watchpoints

Iv temany Display Iv Memary Display
CPU DLL: Parameter: Drriver DLL: Parameter:
|seostoLl | |58051.DLL |
Dialog DLL: Parameter: Dialog DLL: Parameter:
|DP51.DLL |-p51 |TP51.DLL |-p51

Ok | Cancel | Defaults |

Utilities
Options for Target 'IRsamples’

Device | Tarst| Output | Listing| €51 | 451 | BL51 Locate | BLST Misc | Dsbug  Utiities

Configure Flagh Meru Commatd

% Use Target Driver for Flash Programming

| ﬂ Settings

(™ |Usze External Toal far Flash Pragramming

Cammand: | J

Arguments: |

-

ak | Cancel Defaults
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